IPv6: Mengapa tidak menggunakan / 126 pada tautan P2P untuk IPv6?


16

Dalam IPv4 kami menggunakan / 30 untuk menghemat alamat. Jadi mengapa beberapa orang merekomendasikan menggunakan / 64 pada tautan P2P, bukan / 126? Saya bisa menggunakan a / 64 pada subnet biasa tetapi tidak menggunakan a / 64 ketika hanya akan ada dua alamat yang digunakan pada tautan P2P yang membuang banyak sekali alamat?


4
Hai, tolong pertimbangkan perspektif yang diungkapkan dalam RFC 6164
— Mike Pennington

Jawaban:


14

Banyak dari kita yang menggunakan / 126 pada tautan PTP. Saya pribadi suka bisa mengidentifikasi sesuatu sebagai infrastruktur jaringan tautan PTP hanya berdasarkan 64 bit pertama dari alamat, jadi saya memesan a / 64 untuk menarik / 126 dari. Orang yang berbeda memiliki pendapat berbeda tentang apa yang penting, jadi ... angkat bahu

Secara kebetulan (# 1), karena IPv6 tidak memiliki konsep alamat broadcast atau alamat jaringan pada jaringan IP, Anda sebenarnya bisa menggunakan / 127 bukan / 126. Berhati-hatilah bahwa, meskipun netmasks / 127 benar-benar valid, beberapa peralatan vendor tidak memperbolehkannya, mengingat netmasks / 127's "tidak valid", yang berarti Anda mungkin mengalami beberapa masalah dukungan vendor jika Anda memutuskan untuk mencoba menggunakannya. Inilah sebabnya saya menggunakan / 126's.

Secara kebetulan (# 2), jika tautan Anda benar - benar didefinisikan sebagai tautan PTP, Anda harus dapat menggunakan alamat IP apa pun tanpa harus berada dalam jaringan IP yang sama sekali.


1
Bisakah Anda memberikan contoh vendor yang membatasi penggunaan / 127s?
— Ryan Foley

4
Pada satu titik, Brocade di garis FastIron dan mungkin di garis NetIron tidak mengizinkannya. Saya belum memeriksa versi firmware terbaru, jadi saya tidak tahu apakah itu masih terjadi atau tidak.
— Jeff McAdams

1
Brocade juga bukan perusahaan kecil. Wawasan yang bagus.
— Ryan Foley

5

Ada dua bagian dari jawabannya.

Pertama, untuk menjawab pertanyaan Anda secara langsung: rekomendasi resmi tentang topik ini telah berubah. Di masa lalu, RFC 3627 berjudul "Penggunaan / 127 Panjang Awalan Antar Router Dianggap Berbahaya" Namun, rekomendasi saat ini berbeda, RFC 6164 merekomendasikan penggunaan tautan / 127 (bukan a / 126!) Pada tautan point-to-point. Kedua RFC menguraikan alasan untuk masing-masing rekomendasi.

Bagian kedua dari jawabannya adalah bahwa secara umum, di luar tautan point-to-point, IPv6 akan pecah dengan awalan yang lebih panjang dari / 64. Ini sebenarnya bukan IPv6 itu sendiri, tetapi banyak protokol yang digunakannya, seperti SLAAC, Neighbor Discovery, dll. Karena tautan point-to-point tidak melibatkan segala bentuk penemuan, pertimbangan itu tidak relevan, dan / 127 akan bekerja.


5
RFC 6547 mengklarifikasi fakta bahwa RFC 3627 telah dipindahkan ke Status Historis, dan bahwa RFC 6164 menghapuskannya.
— Ron Maupin

3

Karena IPv6 selalu merekomendasikan penggunaan / 64 untuk semua tautan.

Untuk bagian kedua dari pertanyaan, apakah itu sia-sia?

A / 64 memiliki 18.446.744.073.709.551.615 , atau 18 trilyun alamat.

Sebagian besar subnet IPv4 kurang dari 255 host. Asumsikan bahwa Anda memiliki jaringan dengan 255 host di dalamnya dan mereka diberi awalan / 64. Itu berarti bahwa 255 host diberi alamat v6, meninggalkan 18.446.744.073.709.551.360 alamat tidak digunakan. Itu lebih dari 99,99%. Agar lebih akurat, itu enam belas 9's, atau efektif 100% "limbah".

Bahkan jika Anda memiliki subnet dengan 1.000.000 host di dalamnya, itu 18.446.744.073.708.551.616 alamat terbuang, atau masih lebih dari 99,99%. Hanya tiga belas 9 kali ini, tetapi masih efektif 100% "limbah".

Jadi perbedaan persentase antara menggunakan satu juta alamat atau dua alamat pada satu tautan dapat diabaikan.

Dan supaya Anda bisa melihat seperti apa angka-angka ini.

* Two hosts is 99.9999999999999999891579782751449556599254719913005828857422% unused.
* 255 hosts is 99.9999999999999986176422300809818466404976788908243179321289% unused.
* 1M  hosts is 99.99999999999457898913757247782996273599565029144287109375% unused.
* 4B  hosts is 99.999999976716935634613037109375% unused.

Bahkan seluruh Internet IPv4 yang ditempatkan pada satu tautan / 64 akan meninggalkan 100% alamat yang tidak digunakan secara efektif. Ketika Anda melihat angka-angka seperti ini, menggunakan apa pun selain a / 64 pada tautan itu konyol.


2
Banyak ISP yang menggunakan / 126 untuk tautan titik ke titik. Saya kira kebiasaan lama sulit ;-)
— Ron Trunk

Mereka melakukannya, tetapi mudah-mudahan menyadari bahwa seluruh Internet IPv4 masih efektif 0% dari / 64 dapat membawa beberapa perspektif yang tepat.
— bahamat

1
Salah satu alasan yang mungkin (saya bukan ISP) mungkin karena mereka dapat mengambil satu / 64 subnet dan memasukkan semua tautan mereka ke dalamnya. Ini dapat membuat pengelolaan dan pemecahan masalah lebih mudah.
— Ron Trunk

@ Bahaham Saya rasa Anda tidak sepenuhnya menjawab pertanyaan awal Anda. "Karena IPv6 selalu merekomendasikan penggunaan / 64 untuk semua tautan" tidak menjawab "Jadi mengapa beberapa orang merekomendasikan menggunakan / 64 pada tautan P2P, bukan / 126?" .
— Ryan Foley

3
Selain jawaban lengkap saya, saya ingin mengomentari yang satu ini. Pernyataan bahwa IPv6 selalu merekomendasikan penggunaan / 64 untuk semua tautan tidak lagi valid. tools.ietf.org/html/rfc6164
— Jeff McAdams

2

Jadi sebagai ISP, saya ingin menambahkan komentar untuk ini. Secara khusus kami menggunakan baik GUA maupun ULA (alamat lokal unik) untuk rute internal kami. Ini berarti bahwa kami memiliki blok (/ 48) yang berasal dari kumpulan / 32 GUA, tetapi kami memfilter di tepi kami mengubahnya menjadi ULA. GUA yang lebih besar / 32 masih diiklankan, tetapi / 48 ULA disaring di tepi kita. Kami menggunakan ULA ini untuk sebagian besar kebutuhan pengalamatan internal kami (khusus AS) serta tautan PtP.

Semua tautan PtP kami adalah blok / 64 yang lengkap, namun mereka secara khusus dikonfigurasikan sebagai / 127 pada router. Ini untuk secara khusus menangani serangan ping-pong bila memungkinkan di ruang IPv4 dan IPv6. Anda jarang melihatnya di ruang IPv4 karena kita semua menggunakan / 30-an untuk tautan PtP di sana. Namun dalam ruang IPv6, menggunakan / 64 menciptakan kemampuan untuk jenis serangan ini (lihat https://tools.ietf.org/html/rfc6164#section-5.1 )

Seperti disebutkan sebelumnya, mengalokasikan a / 64 untuk tautan-tautan ini sepertinya sia-sia, tetapi begitu Anda menghabiskan banyak waktu membuat rencana alamat IPv6 Anda (bacaan yang baik adalah https://www.amazon.com/IPv6-Address-Planning- Mendesain-Future-ebook-dp-B00PCZMAOW / dp / B00PCZMAOW ) Anda melihat bahwa JAUH lebih mudah untuk tidak pernah menyelidiki melampaui / 64 dalam rencana Anda.

Juga seperti yang disebutkan sebelumnya, karena kita hanya berbicara tentang tautan PtP, a / 127 tidak mengalami masalah normal melampaui a / 64. Mengapa kita tidak menggunakan alamat yang tidak bernomor untuk tautan PtP? Sebagian besar untuk keperluan debugging, jejak, pemantauan, dll.

--- Saya lupa menyebutkan (setelah membaca kembali beberapa komentar di atas ...) Jika Anda menggunakan / 126 sebagai tautan PtP Anda, Anda masih menderita masalah ping-pong yang sama dengan / 64. Mengapa? Karena 00 dan 11 bit di / 126 Anda adalah alamat IPv6 yang valid (sedangkan di IPv4 tidak, mereka melayani tujuan yang berbeda). Jadi meskipun a / 32 (dua bit dari / 32) berfungsi untuk IPv4, a / 127 (1 bit dari / 128) adalah yang Anda butuhkan untuk IPv6.


Sayangnya, operator besar (ATT, VzB, dll.) Bersikeras bahwa /127tautan tidak diizinkan, dan mereka bersikeras bahwa kami menggunakan /126tautan dengan mereka. Kita harus menguji dengan cermat setiap peralatan yang kita gunakan untuk memastikan peralatan itu kebal terhadap serangan pingpong.
— Ron Maupin
Dengan menggunakan situs kami, Anda mengakui telah membaca dan memahami Kebijakan Cookie dan Kebijakan Privasi kami.
Licensed under cc by-sa 3.0 with attribution required.