Memulai server database MySQL mysqld [gagal]


0

Hari ini saya menginstal MySQL di Ubuntu 13.10 saya, dan itu bekerja dengan sangat baik. Tetapi setelah saya me-restart komputer, ketika saya me-restart MySQL, gagal, dan log dari / var / log / mysql adalah:

31216 22:40:25 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
131216 22:40:25 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
131216 22:40:25 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
131216 22:40:25 [Note] Plugin 'FEDERATED' is disabled.
131216 22:40:25 InnoDB: The InnoDB memory heap is disabled
131216 22:40:25 InnoDB: Mutexes and rw_locks use GCC atomic builtins
131216 22:40:25 InnoDB: Compressed tables use zlib 1.2.8
131216 22:40:25 InnoDB: Using Linux native AIO
131216 22:40:25 InnoDB: Initializing buffer pool, size = 128.0M
131216 22:40:25 InnoDB: Completed initialization of buffer pool
131216 22:40:25 InnoDB: highest supported file format is Barracuda.
131216 22:40:26  InnoDB: Waiting for the background threads to start
131216 22:40:27 InnoDB: 5.5.34 started; log sequence number 1609544
131216 22:40:27 [ERROR] /usr/sbin/mysqld: unknown variable 'default-character-set=utf8'
131216 22:40:27 [ERROR] Aborting

131216 22:40:27  InnoDB: Starting shutdown...
131216 22:40:27  InnoDB: Shutdown completed; log sequence number 1609544
131216 22:40:27 [Note] /usr/sbin/mysqld: Shutdown complete

131216 22:40:27 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

Adakah yang bisa membantu saya untuk memperbaiki masalah ini, terima kasih!

mysql 

silakan format keluaran log Anda
— strauberry

Apakah Anda mengatur ini default-character-set di my.cnf?
— Marcus Adams

Jawaban:


1

Tampaknya cukup jelas dari keluaran log. [ERROR] /usr/sbin/mysqld: unknown variable 'default-character-set=utf8'

Saya pikir Anda sedang mencari character-set-server.


Kanan!!! Saya menemukannya sendiri beberapa menit sebelumnya, saya menghapus baris itu di my.cnf, saya menambahkan baris ini ketika saya selesai menginstal mysql, konfigurasi yang salah, terima kasih atas jawabannya

@ user2593783 Jika jawaban ini membantu Anda, Anda dapat menandainya sebagai jawaban "diterima" dengan mengklik tanda centang di sebelah kiri posting ini.
— Anthony Neace
Dengan menggunakan situs kami, Anda mengakui telah membaca dan memahami Kebijakan Cookie dan Kebijakan Privasi kami.
Licensed under cc by-sa 3.0 with attribution required.